Genesys Multicloud CX on-premises (formerly Engage on-premises)

Discussion Thread View
Expand all | Collapse all

Composer

  • 1.  Composer

    Posted 11-21-2017 15:18
    Unable to install Composer plugins in Eclipse as its looking for Internet Connectivity which it will never have . Stalls because it can't find Software being installed: Composer Common 8.1.45.201710021710 (com.genesyslab.composer.common.feature.feature.group 8.1.45.201710021710)  Missing requirement: Composer Common 8.1.45.201710021710 (com.genesyslab.composer.common.feature.feature.group 8.1.45.201710021710)
      requires 'org.eclipse.gmf.runtime.diagram.ui.properties 0.0.0' but it could not be found

    Running Java 8 and Eclipse Mars 4.5.2


  • 2.  RE: Composer

    Posted 01-28-2018 21:04

    Can you try this:
    In a running Eclipse instance, go to Help > Install New Software
    a.) Click Add
    b.)Type something in the Name field, such as Composer.
    c.) Click Archive
    d.) Browse to the com.genesyslab.composer.updateSite.zip file in Composer installation folder
    e.) Click OK
    f.) Check the three Composer Features (Common' , Voice, Route ).
    g.) Click Finish , and click through the license pages. The installation will now begin. This may take some time because other plugin dependencies are downloaded and installed.
    h.) After installation is complete, the Installer will prompt you to restart Eclipse. Click OK

     



  • 3.  RE: Composer

    Posted 05-20-2021 15:17
    Hello,

    Composer i have installed offline and online installation both are not working and i have followed your steps but still the same error.

    Eclipse IDE for Eclipse Committers
    Version: Mars.2 Release (4.5.2)
    Build id: 20160218-0600

    openjdk-8u262-b10-win-64 


    Cannot complete the install because one or more required items could not be found.
    Software being installed: Composer Common 8.1.56.202103111529 (com.genesyslab.composer.common.feature.feature.group 8.1.56.202103111529)
    Missing requirement: Composer Common 8.1.56.202103111529 (com.genesyslab.composer.common.feature.feature.group 8.1.56.202103111529) requires 'org.eclipse.gmf.runtime.diagram.ui.properties 0.0.0' but it could not be found

    ------------------------------
    Lakshmanakumar Krishnasamy
    Infosys Ltd
    ------------------------------



  • 4.  RE: Composer

    GCAP Member
    Posted 05-23-2021 19:10
    You'll need to install GMF Tooling in Eclipse:
    Eclipse software repository | The Eclipse Foundation
    Installation (genesys.com)

    ------------------------------
    Jason McLennan
    Commonwealth Bank of Australia
    ------------------------------



  • 5.  RE: Composer

    Posted 05-24-2021 03:59
    Edited by Lakshmanakumar Krishnasamy 05-24-2021 04:00
    Hello Jason,

    After successful installation of GMF then composer plugins also installed. Now composer is working fine.
    Thanks Jason for response.

    ------------------------------
    Lakshmanakumar Krishnasamy
    Infosys Ltd
    ------------------------------