Genesys Engage on-premises

Discussion Thread View
  • 1.  Composer Installation

    Posted 08-31-2021 09:26
    Hi Everyone,

    Can anyone please let me know which Eclipse is compatible for Composer installation?
    I have tried with the latest Eclipse available on net but its working.

    #Composer

    Thanks,
    Ashish​​​
    #Routing(ACD/IVR)

    ------------------------------
    Ashish Sinha

    ------------------------------


  • 2.  RE: Composer Installation

    GENESYS
    Posted 08-31-2021 10:57
    Edited by Rafael Marciano 08-31-2021 10:58
    Hi Ashish,

    According to the Official documentation, the latest Eclipse version supported by Composer is Photon:
    https://docs.genesys.com/Documentation/Composer/latest/Deployment/Preinstallation

    Regards,





    ------------------------------
    Rafael Marciano
    ------------------------------



  • 3.  RE: Composer Installation

    Posted 09-01-2021 04:29
    Why such an old version?  Looking at the Eclipse webpage, there have been many newer versions.  When will Genesys bring Composer inline with the latest Eclipse?

    Eclipse Packaging Project (EPP) Releases



    ------------------------------
    Ian Middleton
    British Telecommunications PLC
    ------------------------------



  • 4.  RE: Composer Installation

    Posted 09-02-2021 08:35
    Hi Rafael,

    Thanks for the information shared.
    I tried to install Composer on Eclipse Photon that you suggested but getting error and Composer is not getting installed.
    Do you have any idea what is causing this error.

    Error:
    Cannot complete the install because one or more required items could not be found.
    Software being installed: Composer Language Locales 8.1.53.201910181059 (com.genesyslab.composer.common.feature.nl.feature.group 8.1.53.201910181059)
    Missing requirement: Publish 8.1.53.201910181059 (com.genesyslab.composer.common.publish 8.1.53.201910181059) requires 'osgi.bundle; org.eclipse.gmf.runtime.emf.core 1.4.1' but it could not be found
    Cannot satisfy dependency:
    From: Composer Language Locales 8.1.53.201910181059 (com.genesyslab.composer.common.feature.nl.feature.group 8.1.53.201910181059)
    To: org.eclipse.equinox.p2.iu; com.genesyslab.composer.common.publish [8.1.45,8.2.0)


    Thanks,
    Ashish


    ------------------------------
    Ashish Sinha
    Infosys Limited
    ------------------------------



  • 5.  RE: Composer Installation

    GENESYS
    Posted 09-02-2021 08:44
    Hi Ashish,

    When installing Composer in Eclipse, it requires some dependencies, which must be downloaded prior to installing Composer. The pre-reqs can be found here: https://docs.genesys.com/Documentation/Composer/latest/Deployment/Preinstallation. Internet connection is required to install all the dependencies.

    Based on the error you shared in your reply, it seems Composer install failed because of one missing dependency, which is the GMF Tooling Plugin. By going to the "Install New Software" menu in Eclipse, type "GMF" in the url field and it will display the Eclipse repository from where you can download it. After installing GMF Tooling plugin, try to install Composer plugin again.


    Regards,


    ------------------------------
    Rafael Marciano
    ------------------------------