Genesys Engage on-premises

Discussion Thread View

Platform SDK - Create new objects with spanish charset

  • 1.  Platform SDK - Create new objects with spanish charset

    Posted 05-25-2021 07:34
    Hi!,

    First of all, I've searched on the community but I didn't find nothing related to my problem, so I'm openning a new case.

    I'm developing a C# Platform SDK application to create new configuration objects. I can create those objects, there's no problem until I try to use object names with spanish charset, eg: "gestión", "campaña",...

    I'll add some attachments so you can better understand what's happening.

    • on "captura error acentos genesys sdk 2.png" file, you can see that I can create manually from Config Manager application an object with that spanish charset.
    • on "captura error acentos genesys sdk.png" file, you can see the new object I'm creating using Plaform SDK, and it's property Name, with the spanish characters. It seems that there's no problem with the encoding.
    • on "captura error acentos genesys sdk 1.png", you can see the real name that the object created on the previous step has been assigned on Genesys Configuration.
    • on "captura error acentos genesys sdk 3.png" file you can see that the encoding property on config server application, is set to utf-8. In other case, probably I wouldn't be able to create the object manually as on the first step with spanish characters.

    I don't know what the problem can be. I've tried setting the PropertyConfiguration variable, used when creating a new endpoint to connect to Config Server, with UTF-8 encoding but the problem is the same. Next you can see the code:

    PropertyConfiguration configuration = new PropertyConfiguration();
    configuration.UseAddp = true;
    configuration.AddpServerTimeout = 10;
    configuration.AddpClientTimeout = 10;
    configuration.AddpTraceMode = AddpTraceMode.Both;
    configuration.SetOption(CommonConnection.StringAttributeEncodingKey, "UTF-8");
    configuration.StringsEncoding = "UTF-8";
    Endpoint ocsEndpointPrimary = new Endpoint(ocsClientName, ocsHostPrimary, ocsPortPrimary, configuration);


    As It didn't work, I tried even with configuration.SetOption() and with configuration.StringsEncoding, as you can see on the above code.

    I even tried to set the encoding on the PropertyConfiguration object, to windows-1252, but I received an exception saying that I couldn't use that encoding (not sure why).

    Any idea of what else could I try?

    Thanks in advance.

    Regards
    #Integrations

    ------------------------------
    Luis Gonzalez
    Evolutio Cloud Enabler, S.A.
    ------------------------------