Genesys Cloud (formerly PureCloud)

Discussion Thread View
Expand all | Collapse all

WebRTC issues when making new accounts

  • 1.  WebRTC issues when making new accounts

    NEW MEMBER
    Posted 10 days ago

    Hello everyone, I hope someone has an idea or some insight in this issue i'm having at the moment.

    Whenever I make a new user in Purecloud and set up a WebRTC for them the first time they login there seems to be an 80% chance they wil receive the following error when they try to call someone or try to receive a call:

    (i'm translating this from dutch so might very slightly in english)
    "Error during calling

    The station could not be reached. This can be caused by a bad network connection or because multiple sessions are active. If you use a seperate program to make calls you have to enable the option "allow external app to place calls" in your settings"

    We do use an external program to place calls so the first thing i do is make sure that option is enabled. so that cannot be the issue.
    When i do a network connection test the results also seem fine


    Also it is usually a 50/50 chance if i just delete the current WebRTC and make a new one for that user it wil suddenly work correctly.
    However with the last user that encountered this problem this did not solve the problem.

    Also strange is that when the problem randomly goes away after creating a new WebRTC it does not come back for that user (or atleast hasn't yet)

    If anyone has any ideas I'd love to hear them. 

    #SIP/VolP
    #Telephony

    ------------------------------
    Sjiron de Jong
    Individual Only Contact Account
    ------------------------------


  • 2.  RE: WebRTC issues when making new accounts

    Posted 9 days ago
    Hello Sjiron
    Hope you are well.

    When you add the WebRTC phone for the user do you also add it as their default phone? Even when added as the default phone, you may want to check the user has selected the WebRTC phone before using.

    We have experienced, from time to time, we need to re-create WebRTC phones because the user session appears to become stuck, particularly when auto-answer in use.

    Probably you are doing it already but any weird stuff happening in the browser client recommend fully clearing the browser cache.

    ------------------------------
    Thanks and regards
    Blair Wilkinson
    CVT (Global) Pty Ltd
    ------------------------------



  • 3.  RE: WebRTC issues when making new accounts

    NEW MEMBER
    Posted 8 days ago
    Hey Blair,

    Thanks for your reply!
    When this issue pops up it's at the office so I am there to see what goes wrong and make sure all settings are correct.
    I have tried both making the created WebRTC as standard and making them choose the right WebRTC manually sadly this does not make a difference.

    They use the client instead of the webbrowser to use purecloud so i haven't tried clearing the browser cache but it's worth a try.

    ------------------------------
    Sjiron de Jong
    Individual Only Contact Account
    ------------------------------



  • 4.  RE: WebRTC issues when making new accounts

    NEW MEMBER
    Posted yesterday
    Just updating this ticket in case someone runs into the same problem

    for us it was 1 of the 2 servers handling calls (edge servers)

    When you make a webrtc it automatically picks a primary edge and a secondary edge.

    Whenever edge server 2 was picked as primary edge the issues started.

    ------------------------------
    Sjiron de Jong
    Individual Only Contact Account
    ------------------------------