Genesys Cloud CX (formerly PureCloud)

Discussion Thread View
Expand all | Collapse all

SSO returning Oh No something went wrong

  • 1.  SSO returning Oh No something went wrong

    GCAP Member
    Posted 01-30-2019 13:51
    I'm trying to get the AD FS integration to work.  After following the instructions I get an Error Message "Oh No Something went wrong."

    If I go into debug on the Browser and on the network tab I see Im getting a 404

    https://login.mypurecloud.com/request not found.
    #Integrations

    ------------------------------
    Stephen Ward
    Calibrus
    ------------------------------


  • 2.  RE: SSO returning Oh No something went wrong

    GENESYS
    Posted 01-30-2019 14:34
    I don't see /request anywhere in the configuration instructions. I see:

    AWS Region .                     URL
    US East (N. Virginia)        https://login.mypurecloud.com/saml
    EU (Ireland)                      https://login.mypurecloud.ie/saml
    EU (Frankfurt)                   https://login.mypurecloud.de/saml
    Asia Pacific (Sydney)        https://login.mypurecloud.com.au/saml
    Asia Pacific (Tokyo)          https://login.mypurecloud.jp/saml

    So, perhaps trying /saml instead would work?

    ------------------------------
    George Ganahl CCXP, GCA
    Principal Technology Consultant
    Genesys
    ------------------------------



  • 3.  RE: SSO returning Oh No something went wrong

    Posted 01-31-2019 03:00
    We have seen similar error when the SAML signing certificate were changed on IdP and it needed to be update in PureCloud.

    (Note that the SAML certificate must be modified and "-----BEGIN CERTIFICATE-----" and "-----END CERTIFICATE-----" lines must be deleted before .cer file is uploaded to PureCloud)

    ------------------------------
    Jari Riihimäki
    Vintor Oy
    ------------------------------



  • 4.  RE: SSO returning Oh No something went wrong

    GCAP Member
    Posted 01-30-2019 14:49
      |   view attached
    I agree Im using https://login.mypurecloud.com/saml     after I've logged into SSO  I get redirected to the login page which is then throwing an error.

    ------------------------------
    Stephen Ward
    Calibrus
    ------------------------------



  • 5.  RE: SSO returning Oh No something went wrong

    GCAP Member
    Posted 01-31-2019 11:31
    Thanks , yes i've stripped the Begin and End  tags off. Im pretty sure Cert is correct.  

    I appreciate the response , I''ll double check the cert.

    --
    Stephen Ward
    VP of Technology
    Calibrus Call Center LLC





  • 6.  RE: SSO returning Oh No something went wrong

    GCAP Member
    Posted 02-01-2019 17:16
    Thanks I've confirmed the cert is correct. Still getting error after successful login to AD FS.




    ------------------------------
    Stephen Ward
    Calibrus
    ------------------------------



  • 7.  RE: SSO returning Oh No something went wrong

    Posted 04-05-2019 14:06
    If you followed the Microsoft Azure instructions (https://docs.microsoft.com/en-us/azure/active-directory/saas-apps/purecloud-by-genesys-tutorial), so in User Attributes dialog, change the custom claim Email to email.

    This resolved my issue.

    ------------------------------
    Alexandre Souza
    Information Systems do Brasil S/A
    ------------------------------



  • 8.  RE: SSO returning Oh No something went wrong

    Top 25 Contributor
    Posted 11-14-2020 17:07
    Hi Stephen

    What was the solution in the end for you on this?

    ------------------------------
    Vaun McCarthy
    NTT New Zealand Limited
    ------------------------------



  • 9.  RE: SSO returning Oh No something went wrong

    Posted 11-13-2019 12:29
    Hello
    Please help.
    In the step 4 is necessary put https://login.mypurecloud.com (of respective region) like Identifier?

    In the Basic SAML Configuration section, if you want to configure the application in IDP-initiated mode, enter the values for the following fields:

    a. In the Identifier box, enter a URL that corresponds to your region:



    ------------------------------
    Gladys Galabay
    High Telecommunications Sociedad de Telecomunicaciones Cia. Ltda.
    ------------------------------



  • 10.  RE: SSO returning Oh No something went wrong

    GENESYS
    Posted 11-14-2019 11:38
    Step 4 is only required if you want to configure the application in IDP-initiated mode - where the identity provider, not the service provider, initiates SSO. For example, if you prefer that your users access PureCloud via a portal, rather than the PureCloud login page.

    Here is a good article that explains the difference between IDP and SP initiated SSO.




    ------------------------------
    Becky Powell
    Principal Product Manager, PureCloud Open Platform
    Genesys - Employees
    ------------------------------



  • 11.  RE: SSO returning Oh No something went wrong

    Posted 5 days ago
    Dear Becky,
    We have the same problem.
    We planed to continue our integration work on Monday 11.10.2021 at 13:00 (Israel time) and we will be happy if You or some engineer from Your team will take place in our integration/tests.


    ------------------------------
    Best regards,

    Yvgeni Liberman
    ITNavPro
    ------------------------------



  • 12.  RE: SSO returning Oh No something went wrong

    GENESYS
    Posted 11-16-2020 17:25
    Hello @Vaun McCarthy and @Stephen Ward,

    I spoke with the Dev lead for our Auth service on this topic today. Unfortunately, there is not enough information in this thread ​​for him to troubleshoot with any accuracy.

    If you would, please open a case with our Care team to investigate - and let me know the case number so that I can escalate accordingly and get you the fastest response possible. You can reach me at becky.powell@genesys.com.

    Again, I am very sorry for your frustration here.

    ------------------------------
    Becky Powell
    Principal Product Manager
    Genesys - Employees
    ------------------------------



  • 13.  RE: SSO returning Oh No something went wrong

    GCAP Member
    Posted 11-14-2020 18:19
    No solution . terrible genesys support as always. so I gave up.

    ------------------------------
    Stephen Ward
    Calibrus
    ------------------------------



  • 14.  RE: SSO returning Oh No something went wrong

    GENESYS
    Posted 11-14-2020 18:36
    Oh dear. Stephen, this is not our intent at all. Please let me take this issue to our developer team on Monday and I will return with more detail, since my original answer did not suffice.

    Terribly sorry and always here to help,

    Becky

    ------------------------------
    Becky Powell
    Principal Product Manager
    Genesys - Employees
    ------------------------------



  • 15.  RE: SSO returning Oh No something went wrong

    Top 25 Contributor
    Posted 11-16-2020 00:15
    This might be a good topic for the next Q&A show :)

    ------------------------------
    Vaun McCarthy
    NTT New Zealand Limited
    ------------------------------



  • 16.  RE: SSO returning Oh No something went wrong

    Posted 8 days ago
    Hi @Stephen Ward,

    Did you finally get it to work?

    I have the same problem with Okta, when i try to login trought Okta (Genesys Cloud app in Okta), open in a new window with Genesys saying "Oh no! Something went wrong"....

    I tried to contact with customer support but they say they don't know where to apply the parameters "email" and "ServiceName" and giving that answer they are satisfied? Pitiful.

    @Becky Powell could you help me?

    Thanks in advance.
    Regards.​​​

    ------------------------------
    Carlos Camacho Jimenez
    Evolutio Cloud Enabler S.A.
    ------------------------------



  • 17.  RE: SSO returning Oh No something went wrong

    GENESYS
    Posted 5 days ago
    Hi Carlos, can you please share with me your Care case ID? Feel free to email me directly at becky.powell@genesys.com and I'll do my best to help.

    ------------------------------
    Becky Powell
    Principal Product Manager
    Genesys - Employees
    ------------------------------



  • 18.  RE: SSO returning Oh No something went wrong

    GENESYS
    Posted 5 days ago
    Hi there Yvgeni, could I ask you to please report your issue to Care and share the case ID with me so that I may follow up? Thank you!

    ------------------------------
    Becky Powell
    Director, Product Management
    Genesys - Employees
    ------------------------------