Genesys Cloud (formerly PureCloud)

Discussion Thread View
Expand all | Collapse all

Problems with WebRTC connections

  • 1.  Problems with WebRTC connections

    Posted 03-26-2020 02:27
    It is common from time to time for Genesys Cloud users to have problems answering incoming calls. Of which the documented solution is to clear the cache in the browser, log out of Genesys Cloud application and reboot your computer.

    I will like to share with the team two additional steps we took  in our environment to clear the cache. After we cleared the cache in the browser and restarted the computer of the users with the problem, the problem was still not solved. So we went two steps forward by clearing the cache of the users home router through a restart of the router, and also flushed the DNS from their machine with the command IPCONFIG /FLUSHDNS. This took care of the problem
    Regards


    #Routing(ACD/IVR)

    ------------------------------
    Samuel Effange
    Nissan North America, Inc.
    ------------------------------


  • 2.  RE: Problems with WebRTC connections

    Posted 03-26-2020 12:20
    If you run into DNS issues with WebRTC, have you tried using Google's DNS (8.8.8.8 and 8.8.4.4) for your users DNS servers?

    WebRTC uses Google Cloud for STUN and this may help with DNS related issues. Just a thought.

    Thanks,
    Daniel McLeod

    ------------------------------
    Daniel McLeod
    Qsect LLC
    ------------------------------



  • 3.  RE: Problems with WebRTC connections

    Posted 11-25-2020 23:18
    Hi Sam,
    Would you be able to share some details of the problem in answering incoming calls?
    Is it like, the user clicks on the 'Answer' button during an incoming call, but then the call did not connect/established?  And if the caller did not hang up right away, the user will see "Failed to connect your persistent connection. It can take up to 30 seconds to reconnect after a previous unexpected disconnect." and/or "The WebRTC session has encountered network error in reaching the Edge. If this error persists, contact an administrator"?

    Thanks.


    ------------------------------
    Greg Caballero
    Nexon Asia Pacific
    ------------------------------