Genesys Cloud CX

Discussion Thread View
  • 1.  S3 Integration

    Posted 10-06-2021 16:13
    Edited by Paul Thorburn 10-06-2021 16:19
    Hello!

    I am having a bit of an odd issue with the S3 integration and was wondering if anyone here has ran into anything similar.

    When i download a recording from the API (/api/v2/conversations/{conversationId}/recordings/{recordingId}) i can download in several formats WAV, WEBM, WAV_ULAW, OGG_VORBIS, OGG_OPUS, MP3, NONE. I can then use FFMPEG to convert any of these formats to any other formats without any issue.

    Our trunk is configured to save the files in opus format and when I save files with the S3 integration I am able to convert the audio but it spews out a pile of errors\warnings 
     
    [opus @ 0x55580f186080] Error parsing the packet header.
    Error while decoding stream #0:0: Invalid data found when processing input
     
    From what I can tell when you use the API to retrieve an opus recording it is using 'encoder=Lavc58.134.100 libopus' while files saved by the S3 integration are saved with 'Encoded with Interactive Intelligence, Inc..'


    Has anyone had any success converting recordings from the S3 integration? Or know why they are encoded differently?

    Cheers,
    Paul

    #Integrations


  • 2.  RE: S3 Integration

    Posted 10-06-2021 22:00
    Edited by Paul Thorburn 10-06-2021 22:00
    After some more poking around it does not appear to be related to the codec, i get the above error when Dual Channel is enabled. With Dual Channel disabled i can convert it without any warnings\errors.

    At this point I'm still not sure how to convert them, i have tried a bunch of different ffmpeg commands but no luck.

    Cheers,
    Paul