PureConnect

 View Only
Discussion Thread View
  • 1.  Interaction Connect - IA configuration?

    Posted 02-14-2018 14:46
    I didn't see a Interaction Connect form, so not sure if this question is best placed here or webservices but though i would start here. I am implementing Interaction Connect following the CIC Web Applications Installation and Configuration Guide. I have the IIS server configured and the Interaction Connect Page accessible, the issue is when i am trying to connect to a CIC Server, it errors out saying can't connect to server. Debugging the page i see: http://clmb-i3iisdev/client/api/i3cic-dev-a/icws/connection/version 404 (Not Found) http://clmb-i3iisdev/client/api/i3cic-dev-a/icws/connection/features 404 (Not Found) Is there configuration that needs to be done on the CIC server to accept these request, like there was for Chat? I didn't see anything about it in the guide and wondering if there is another guide that overs that part. Thank you Scott


  • 2.  RE: Interaction Connect - IA configuration?

    Posted 02-14-2018 16:26
    When you look at the path that IIS is trying to use to hit that API on your CIC, does it show a local path on your web server? If so, it is a sign that proxy isn't enabled.


  • 3.  RE: Interaction Connect - IA configuration?

    Posted 02-14-2018 18:57
    Originally posted by alael;36707
    When you look at the path that IIS is trying to use to hit that API on your CIC, does it show a local path on your web server? If so, it is a sign that proxy isn't enabled.
    What proxy isn't enabled? i saw no mention of any proxy in the Configuration Guide. Thank you, Scott


  • 4.  RE: Interaction Connect - IA configuration?

    GENESYS
    Posted 02-14-2018 19:11
    Page 4 in the CIC Web Applications ICG: 3. Enable server as proxy and enable response buffering: a. In IIS Manager, click your server. b. Double-click the Application Request Routing Cache module. c. In the Actions pane, click Server Proxy Settings. d. Check Enable proxy. e. Change the Response buffer threshold (KB) setting under "Buffer Setting" to 0. f. Click Apply


  • 5.  RE: Interaction Connect - IA configuration?

    Posted 02-14-2018 19:21
    wow, i somehow totally over looked that, maybe time to get my eyes checked. Thank you, Scott


  • 6.  RE: Interaction Connect - IA configuration?

    GENESYS
    Posted 02-14-2018 19:40
    No...easy thing to miss. I know I've flown right past it before.


  • 7.  RE: Interaction Connect - IA configuration?

    Posted 02-15-2018 15:41
    I think if you load the XML file it may disable that proxy function as we just rolled out the web apps yesterday and had the same problem. Couldn't connect and then found the proxy was disabled but the other engineer said he did that step. He did mention something about the configuration file not being complete as well but I didn't get all the details as to what was wrong with the guide.