PureConnect

Discussion Thread View
Expand all | Collapse all

Crystal Report

Jump to Best Answer
  • 1.  Crystal Report

    NEW MEMBER
    Posted 09-19-2020 11:39
    Dears,

    Have A good day for all.

    I have upgraded pureconnect System from 2020 R2 P7 to 2020 R3 P2, and i am facing issue in Interaction reporter Crystal Report.
    during the Running reports, I am getting "An exception has Occurred, the details have been looged"

    after reading the logs, I can see the below:

    CrystalReportExecutor.SetParametersToInputValues : Parameter Media Type defined in ReportData but does not exist in the report.
    CrystalReportExecutor.SetParametersToMetadataDefaults : Parameter User List defined in metadata but does not exist in the report.
    CrystalReportExecutor.SetParametersToMetadataDefaults : Parameter User defined in metadata but does not exist in the report.
    CrystalReportExecutor.SetParametersToMetadataDefaults : Parameter Date Time Range defined in metadata but does not exist in the report.
    CrystalReportExecutor.SetParametersToMetadataDefaults : Parameter Media Type defined in metadata but does not exist in the report.
    CrystalReportExecutor.SetParametersToInputValues : Parameter DNIS(Report Group) defined in ReportData but does not exist in the report..
    .
    .
    .
    .
    .
    the Crystal Report reports were working fine before upgrading, and after upgrading i can see this issue just in case Crystal Reports where the active reports are working fine.

    it there any idea please to assist me?

    Warm Regards,
    Mohammad Almomani
    #Reporting/Analytics

    ------------------------------
    Mohammad Almomani
    Duqm Data Centre SAOC (D2C) OMAN
    ------------------------------


  • 2.  RE: Crystal Report

    GENESYS
    Posted 09-21-2020 09:29
    Hey Mohammad!

    This is a known issue caused by DLL versioning. The solution is to install ICBM after Crystal Reports.

    If you have already got both installed, you should only need to un-install then re-install ICBM.

    HTH

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 3.  RE: Crystal Report

    NEW MEMBER
    Posted 09-21-2020 09:38
    Thank you for your reply,,

    But i am facing this issue even from CIC server.
    I mean when I open ICBM from the server i can see this issue

    ------------------------------
    Mohammad Almomani
    Duqm Data Centre SAOC (D2C) OMAN
    ------------------------------



  • 4.  RE: Crystal Report

    GENESYS
    Posted 09-21-2020 10:47
    Edited by Paul Simpson 09-21-2020 10:54
    Are you saying you have you installed Crystal on the Server? That is a no-no!

    Crystal only needs / should be installed on the workstation(s) belonging to those users who edit reports.

    I will also go so far as to say that you should not routinely be logging into the server's desktop anyway. ICBM, IA, Attendant and so on are supposed to be run from a client PC.

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 5.  RE: Crystal Report

    NEW MEMBER
    Posted 09-21-2020 16:19

    Thank you Paul,

    that is right, after re-install ICBM the reports are working fine



    ------------------------------
    Mohammad Almomani
    Duqm Data Centre SAOC (D2C) OMAN
    ------------------------------



  • 6.  RE: Crystal Report
    Best Answer

    GENESYS
    Posted 09-21-2020 17:27
    Excellent!

    Will you do me a favor? Please mark the solution above as the answer - this helps others who face similar problems.

    Thanks!

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------