PureConnect

Discussion Thread View
Expand all | Collapse all

Problem with UserConfiguration

  • 1.  Problem with UserConfiguration

    NEW MEMBER
    Posted 21 days ago
    Hi to all;

    I stuck with the following case and need your help.

    The following code is supposed to return me the list of all roles assigned to the specified user:

    C# code sample for Remove Role

    However,  configurationObject.Roles always returns null -- double-checked and verified that the specified user has an assigned role.

    The referenced libraries belong to the latest version of ICELib and are as follows:

    • ININ.Common-w64
    • ININ.IceLib-w64
    • ININ.IceLib.Configuration-w64
    • ININ.IceLib.People-w64

    Did you ever encounter with such problem? What is the workaround?

    Thank you in advance.

    Best regards,

    Eli

    P.S. While debugging, I have noticed that UserConfiguraionList.Roles says not initialized.



    #Integrations

    ------------------------------
    Ali Koyuncu
    Asseco SEE Bilisim Teknolojileri A.S.
    ------------------------------


  • 2.  RE: Problem with UserConfiguration

    GENESYS
    Posted 20 days ago
    Ok, so a VERY quick look.

    I see you are pulling back the user from the userId.

    Then, when you set up your filter, you are filtering on the ID, but providing the user....

    Not sure if that's your issue, but worth checking ;-)

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------