PureConnect

Discussion Thread View
Expand all | Collapse all

Very basic Play Audio handler just doesn't seem to work?

  • 1.  Very basic Play Audio handler just doesn't seem to work?

    Posted 02-19-2021 12:52
    Hello,

    I am just starting to get my feet wet when it comes to Handlers.  I have read quite a bit on how they work - I think I understand basic navigation of Designer, how to publish them, and what many of the tools do.

    My thought process for setting up my first basic handler was to create one which I could simply call from Attendant which would play an audio file.  I would then build from there to get the handler to do something useful, like read a string from a database table and play it back to the caller.

    So I created a handler which originally just had two steps: The start step, and a "Play Audio" step.  I published it.

    Then I went into Attendant and in a testing profile, after a generic greeting, I added a Run Subroutine operation, and put the name of my handler (without the .ihd).

    When I call my test number I hear the generic greeting repeat endlessly.  It shows in the interaction log that it's getting to the step where it should be calling the handler but I can't tell if the handler isn't being triggered, or if the handler is running and exiting.

    I did a bunch of searches for people having similar issues, I tried adding a "set Call State" step to claim control of the call, and a Flush Audio step before playback, but neither is working.

    I have tried calling my .wav file both by just the filename (it is in my D:\I3\IC\Resources folder) and by full path name.  I also tried changing the step to a simple "Play String" and put "1234" as my string but nothing is being played back.  Just my greeting .wav on repeat.

    I'm sure I'm missing something quite simple & basic here.

    Thanks in advance.
    #Handlers

    ------------------------------
    Josh Bell
    Shield Healthcare
    ------------------------------


  • 2.  RE: Very basic Play Audio handler just doesn't seem to work?

    Posted 02-19-2021 13:04
    Hi Josh,

    To call a handler directly from Attendant, you need to add it to customsubroutineinitiatorrouter.ihd
    Once you add you handler in there, it will get called when Attendant processes this step.

    Regards

    ------------------------------
    Vineet Kakroo
    FIL Investment Management Ltd
    ------------------------------



  • 3.  RE: Very basic Play Audio handler just doesn't seem to work?

    Posted 02-19-2021 14:55
    This did the trick! Thanks!

    ------------------------------
    Josh Bell
    Shield Healthcare
    ------------------------------



  • 4.  RE: Very basic Play Audio handler just doesn't seem to work?

    GENESYS
    Posted 02-19-2021 13:23
    Josh,

    I highly recommend you attend the Interaction Center Handler Development class. Not only is the process for calling a handler from Attendant covered (you need to modify a handler named customsubroutineinitiatorrouter) but is also covers some important information concerning how to modify handlers in a way that will not void your support.

    HTH

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 5.  RE: Very basic Play Audio handler just doesn't seem to work?

    Posted 02-19-2021 14:00
    Thanks Paul.  I am going through a non-instructor-led version of that course, I likely missed the reference to customsubroutineinitiatorrouter.  Thanks.

    ------------------------------
    Josh Bell
    Shield Healthcare
    ------------------------------



  • 6.  RE: Very basic Play Audio handler just doesn't seem to work?

    GENESYS
    Posted 02-19-2021 16:29
    Josh,

    Chapter 4.1 "Interaction Attendant Handlers", bottom of page.
    Chapter 5.1 "Subroutine Initiator Operator"
    Lab 18

    HTH

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------