PureCloud

Discussion Thread View
Expand all | Collapse all

Progressive Dialler Latency

  • 1.  Progressive Dialler Latency

    Posted 11 days ago
    Hi All

    The below question applies to the Progressive Outbound Dialler.

    Does anyone experience intermittent latency between the time a call is identified as 'live voice' and the time the call is physically connected to the available agent?

    For example: Agent A on queue and available for an interaction, the progressive dialler calls one contact and identifies this as 'live voice'. The interaction is routed to Agent A however it takes 5 seconds for the agent to physically connect to the call. By the time the call is connected, the customer has already hung up.

    For the above example, Agent A was on 'auto-answer' and was readily available to answer the call. The agent uses the SIP Softphone configuration.

    Does this happen to anyone else? Does anyone know what causes this and how to alleviate this? This is obviously a very poor customer experience.

    I've already logged a job with support however would like to see if anyone has any tips.

    Thanks
    #Outbound
    #Routing(ACD/IVR)

    ------------------------------
    [Peter] [Dimatulac]
    [BizCover][Workforce Optimisation Manager][Australia]
    ------------------------------


  • 2.  RE: Progressive Dialler Latency

    GENESYS
    Posted 11 days ago
    This happens to everyone, to some extent. 5 seconds is longer than usual, so you should probably open a case with customer care to see if they can help you tune the process. The minimum delay is about two seconds.


    ------------------------------
    George Ganahl CCXP, GCP
    Principal Technology Consultant
    Genesys
    ------------------------------



  • 3.  RE: Progressive Dialler Latency

    Top 25 Contributor
    Posted 8 days ago
    If it helps i raised a case about this recently, i put it down to the call analysis not working in the background properly unfortunately in this particular case i raised i was passed around and i eventually was dissatisfied as each case manager asked me to re-submit the same information over and over they kept dropping the ball.
    While i tested various contact lists with/without call analysis it doesnt really make a difference when it comes to New Zealand English and Australian English as they both reference each other.

    I have noticed over the last 4 weeks at least that the connection time of (default) 2 seconds between a customer saying "Hello" and connecting with an agent who is on auto-answer has been increasingly delayed between 5-7seconds as an extreme but given the amount of calls we connect to using (Power) you tend to lose track of it, it normally is identified when searching/listening to calls to identify another issue that you can see the timeline and recording.

    Sorry can't be of more help


    ------------------------------
    Darryn Chang
    Stuff Limited
    New Zealand
    2 Years Purecloud
    ------------------------------



  • 4.  RE: Progressive Dialler Latency

    Posted 8 days ago
    Thanks for the insight Darryn. Glad I'm not the only one seeing this so I can rule this out as being an environmental issue.

    I initially picked this up through sheer luck by listening to calls however I have since introduced a daily audit as this can have damaging impacts on our business.

    I've also raised a case so here's to hoping they can take ownership and find a solution.


    ------------------------------
    [Peter] [Dimatulac]
    [BizCover][Workforce Optimisation Manager][Australia]
    ------------------------------