PureConnect

 View Only
Discussion Thread View
  • 1.  Issue Calling GetRecordingUri

    Posted 11-18-2021 11:07
    I've been tasked with unwrapping Lumber Liquidator's so they can be played as .wav files.
    I developed a C# program that queries the PureConnect database for a date range of recordings, and them loops across the result set calling GetRecordingUri for each recording.
    It works fine on my system, but fails on their server. I'm getting the following error:

    E 10:37:38.5732592_0000 RecordingsManager.GetExportUriImpl : InstanceId=3
    Top Exception
    Type=ININ.IceLib.IceLibException
    Source=ININ.IceLib.QualityManagement-w64
    Message=Insufficient privileges: User * does not have sufficient privileges for object *
    StackTrace:
    at ININ.IceLib.QualityManagement.RecordingsManager.GetExportUriImpl(String recordingId, RecordingMediaType mediaType, String screenRecordingParticipantId, Int32 attachmentId, Boolean requestHTTPS) in d:\builds\eic_2021r2_p00\products\eic\src\icelib\QualityManagement\RecordingsManager.cs:line 1865


    StackTrace:
    at RecordingsManager.GetExportUriImpl(String recordingId, RecordingMediaType mediaType, String screenRecordingParticipantId, Int32 attachmentId, Boolean requestHTTPS) d:\builds\eic_2021r2_p00\products\eic\src\icelib\QualityManagement\RecordingsManager.cs(1865)
    at RecordingsManager.GetExportUri(String recordingId, RecordingMediaType mediaType, String screenRecordingParticipantId, Int32 attachmentId) d:\builds\eic_2021r2_p00\products\eic\src\icelib\QualityManagement\RecordingsManager.cs(1827)
    at Program.<Main>g__GetRecordingUri|0_0(String recordingId, RecordingMediaType mediaType, String screenRecordingParticipantId, Int32 attachmentId, <>c__DisplayClass0_0& ) C:\Users\wrodeback\source\repos\ExportRecordings\Program.cs(102)
    at Program.Main(String[] args) C:\Users\wrodeback\source\repos\ExportRecordings\Program.cs(65)
    IceLib_QualityManagement 0x26b0

    What permissions am I missing? I'm logged in as the IC Administrator, and am using WindowsAuth settings. I don't know what the problem is.
    #Unsure/Other

    ------------------------------
    Wayne Rhodeback
    Emplifi
    ------------------------------


  • 2.  RE: Issue Calling GetRecordingUri

    Top 25 Contributor
    Posted 11-18-2021 11:30
    Can the user you are authenticating to their system as access recordings manually via ICBM?

    Sounds like they are missing a permission or two...

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 3.  RE: Issue Calling GetRecordingUri

    Posted 11-18-2021 12:16
    Ah, I'll check licensing! Based on the message, I kept looking at permissions.

    ------------------------------
    Wayne Rhodeback
    Emplifi
    ------------------------------



  • 4.  RE: Issue Calling GetRecordingUri

    Top 25 Contributor
    Posted 11-18-2021 12:35
    That too!

    Let us know how you get on.

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 5.  RE: Issue Calling GetRecordingUri

    Posted 11-22-2021 10:37
    I've checked everything. Fully licensed. all permissions, etc. Nothing works.

    ------------------------------
    Wayne Rhodeback
    Emplifi
    ------------------------------



  • 6.  RE: Issue Calling GetRecordingUri

    Posted 11-22-2021 11:27
    You are looking at the rights in Policy Manager correct?   Maybe IC admin is not tied to those security rights there?

    ------------------------------
    ryan hedlund
    ------------------------------



  • 7.  RE: Issue Calling GetRecordingUri

    Top 25 Contributor
    Posted 11-22-2021 11:32
    Can you confirm whether the user you are authenticating as can perform these actions using ICBM?

    We need to figure out if it's down to the user config or your application.

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 8.  RE: Issue Calling GetRecordingUri

    Posted 12-13-2021 08:02
    Edited by Wayne Rhodeback 12-13-2021 08:04
    I opened a Support ticket on this. While waiting for an answer there, I figured out the problem.
    It was recording policies. Something was screwy. I could add the account to the policy, it wouldn't show. So I finally just granted the full power configuration to everyone.


    ------------------------------
    Wayne Rhodeback
    Emplifi
    ------------------------------