Genesys Cloud (formerly PureCloud)

Discussion Thread View
Expand all | Collapse all

THE HEADSET DOES NOT WORK FOR UNKNOW REASON

  • 1.  THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 12-12-2019 12:32
    Hi
    Please somebody have this problem: We have a customer and 2 agents have problems with their headset, at 10am and 4pm the headset does not work,  in the UI the audio device appear but the agent can not make or receive calls.
    The headset work again, only when the machines are restarted.
    In the pcsoftphone logs we find this:
    softphone::AudioResource::get_soft_station_resource : Caught standard exception creating the SoftStation resource:
    ErrorCode: error.softphoneengine.audioresource.createresource
    Description: failed to create SoftStation resource

    softphone::AudioResource::start : Caught standard exception creating the SoftStation resource:
    ErrorCode: error.icmediaserveraudio.api.invalidParameter
    Description: Error creating duplex audio device (Input='sipsoftphone:Default Communications Device', Output='sipsoftphone:Default Communications Device')
    Hostname: UIVMT9910
    Function: icmediaserveraudio::GraphSoftStation::open_or_modify_devices()
    File(Line): //media/main_systest/int/src/icmediaserveraudio/graph_soft_station.cpp#16(1891)
    Parameters:
    'deviceAudioInput' => "sipsoftphone:Default Communications Device"
    'deviceAudioOutput' => "sipsoftphone:Default Communications Device"
    Nested:
    ErrorCode: error.hpaa.wasapi.capture
    Description:
    Initialize device failed, totalBufferSize=3200000, waveFormat:
    Legacy Format Tag = (65534) Microsoft Windows Extensible Format Tag
    Channels = 1
    Samples Per Second = 44100
    Average Bytes Per Sec = 176400
    Block Align = 4
    Bits Per Samples = 32
    Additional Data Size = 22
    Valid Bits Per Samples= 32
    Samples Per Block = 1
    Channel Mask = 4
    Extensible Format = {00000003-0000-0010-8000-00aa00389b71}
    Hostname: UIVMT9910
    Function: hpaa::wasapi::WasapiAsyncInput::initialize()
    File(Line): //media/main_systest/int/src/hpaa/wasapi_wrapper.cpp#5(727)
    Parameters:
    'totalBufferSize' => "3200000"

    Some idea for resolve this problem?
    #Telephony

    ------------------------------
    Gladys Galabay
    High Telecommunications Sociedad de Telecomunicaciones Cia. Ltda.
    ------------------------------


  • 2.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    GENESYS
    Posted 12-12-2019 12:35
    I recommend that instead of letting the softphone use the Windows Default Communication Device, you set it instead to the specific headset.

    That setting is accessed by right-clicking the softphone icon in the Systray in Windows, select Audio Configuration, and "Use custom device settings".

    ------------------------------
    George Ganahl GCP (PureCloud) ICCE
    Principal Technology Consultant
    Genesys
    ------------------------------



  • 3.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 12-13-2019 09:09
    Thanks George
    In all the machines the headset are set like you said
    "Default Communication Device"

    ------------------------------
    Gladys Galabay
    High Telecommunications Sociedad de Telecomunicaciones Cia. Ltda.
    ------------------------------



  • 4.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    GENESYS
    Posted 12-13-2019 09:17
    I am recommending you do not use "Default Communication Device". Did you try changing it to the specific headset on one of the problem stations to see if it makes a difference?

    ------------------------------
    George Ganahl GCP (PureCloud) ICCE
    Principal Technology Consultant
    Genesys
    ------------------------------



  • 5.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 12-13-2019 09:28
    Sorry George

    Ok, I going to test your recommendation
    Thanks

    ------------------------------
    Gladys Galabay
    High Telecommunications Sociedad de Telecomunicaciones Cia. Ltda.
    ------------------------------



  • 6.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 10-29-2020 05:45
    Hello Gladys,

    Have you managed to solve this issue? I faced with the same one, tried George's advice, but without success...

    ------------------------------
    Anton Karelin
    Jet Infosystems
    ------------------------------



  • 7.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 22 days ago
    Hi Anton,

    If you have anti-virus installed, disable it and try

    ------------------------------
    Mohammed Bazzi
    Viacomms Telecom KSCC
    ------------------------------



  • 8.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 22 days ago
    Hi Mohammed,

    Thank you for your response. We already have solved this issue and the problem was exectly with antivirus.

    ------------------------------
    Anton Karelin
    Jet Infosystems
    ------------------------------



  • 9.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 22 days ago
    Perfect :)

    ------------------------------
    Mohammed Bazzi
    Viacomms Telecom KSCC
    ------------------------------



  • 10.  RE: THE HEADSET DOES NOT WORK FOR UNKNOW REASON

    Posted 21 days ago
    Can I ask what headset and what anti-virus software was involved?  Disabling the anti-virus doesn't seem to be a "solution".  More of a temporary workaround.  Is there a long term solution available?

    ------------------------------
    Marty Hand
    National Domestic Violence Hotline
    ------------------------------