PureConnect

Discussion Thread View
Expand all | Collapse all

Remote number issues

  • 1.  Remote number issues

    Top 25 Contributor
    Posted 12 days ago
    Hi

    We have one user who is working from home who is using remote number but when setting her mobile number as remote number, Genesys calls the mobile number but then disconnects with the error "There Were No Circuits Available To Contact Your Station".

    We have tried the following troubleshooting...

    Used my number on her interaction desktop as remote number: This worked as expected
    Called her number from interaction desktop manually: call connected no problems
    Used her daughters phone number for remote number: This works as expected (her and her daughter are on the same carrier [EE])
    Used her number on my interaction desktop as remote number: This DID NOT WORK

    All troubleshooting points towards Genesys having a problem calling her phone as remote number. The number presented on her mobile is the correct outbound ANI for our call center.

    I've never seen this before and its completely stumped us.

    any thoughts on what else we could try?
    #Outbound
    #Telephony

    ------------------------------
    Chris Tancred
    IKEA Limited
    ------------------------------


  • 2.  RE: Remote number issues

    GCAP Member
    Posted 12 days ago
    When you called the number from Interaction Desktop, did you prefix it with +1?  Remote numbers will use that prefix, and use the dial plan entries associated with that prefix as well.

    ------------------------------
    AARON LAEL
    State of Utah
    ------------------------------



  • 3.  RE: Remote number issues

    Posted 12 days ago
    We had similar issues some time ago and it turned out that the calling number that we use on our outbound was blocked at the remote mobile number. It seems to be more common on Samsung phones. It's worth checking that.

    Regards

    ------------------------------
    Vineet Kakroo
    FIL Investment Management Ltd
    ------------------------------



  • 4.  RE: Remote number issues

    Top 25 Contributor
    Posted 12 days ago
    We have checked the blocked list on the phone and the outbound number isn't blocked. we've also dialed directly from my user on genesys (which uses the default outbound ani) and that connected fine. Seems like its only a problem when uusing remote number

    ------------------------------
    Chris Tancred
    IKEA Limited
    ------------------------------



  • 5.  RE: Remote number issues

    Top 25 Contributor
    Posted 12 days ago
    Hi,

    We prefix the mobile with the UK country code (+44). This is in the dial plan. Even if it wasn't in he dial plan then it wouldn't work for all the other mobile numbers we have used on her desktop as remote number.

    ------------------------------
    Chris Tancred
    IKEA Limited
    ------------------------------



  • 6.  RE: Remote number issues

    GENESYS
    Posted 12 days ago
    Do you have Basic Station licenses available (unassigned)?

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 7.  RE: Remote number issues

    Top 25 Contributor
    Posted 11 days ago
    Hi Paul,

    Yes we have plenty of basic station licenses available. If not we would have expected the same error when we tried using different mobile numbers right after one another. However, all mobiles worked bar the original users.

    ------------------------------
    Chris Tancred
    IKEA Limited
    ------------------------------



  • 8.  RE: Remote number issues

    Posted 11 days ago
    try to simulate the remote number in the dial plan, (interaction administrator). check the localization as well.
    read the log / compare the log with the working one.

    ------------------------------
    Vincent Heijmans
    BMW Group Munich
    ------------------------------



  • 9.  RE: Remote number issues

    Top 25 Contributor
    Posted 11 days ago
    We also tried this process. when we simulated the call using the dial plan it came out as expected, as did simulating the call to my/my colleagues mobile. We tested with her location and also our default location. There was no evidence of any issues.

    The log files in interaction desktop only showed the message "There Were No Circuits Available To Contact Your Station" it didn't give me any extra information as to why, any SIP error codes or any warning messages prior/after the call being made.

    ------------------------------
    Chris Tancred
    IKEA Limited
    ------------------------------



  • 10.  RE: Remote number issues

    Posted 11 days ago
    When using Remote Number to answer a queue call (or other external call), the system will send the caller's ANI to the cell phone.  This may be why the call is blocked.  I am not sure how the cell carrier determines the ANI has been spoofed, but they don't like it and will block the call.  This is why you can call the cell phone from an internal extension, but external calls fail.
    To address this, you can create a new (outbound only) line based on your normal outbound line, along with a line group to contain it.  Then assign this as the Line Group under Def Station Config-Remote Station tab.
    The line needs to be altered from the default by changing setting on the Identity (Out) page of the SIP Line Config tab.  In the Calling Address (Diverted Calls) section, change From Header Address and Name values from "Use passed values if present" to "use line value 1"  - this allows you to set the Name and Address info in the Calling Address - Line Value 1: section (at the top of the page), so the system will pass the Line's ANI rather than passing the caller's ANI to the cell phone.
    Test this on your Dev server first, or after-hours, just in case...
    To quickly reverse the change, just clear the Line Group from the Def Station Config.  Changes to this value are dynamic; in other words, nothing needs to be restarted.

    ------------------------------
    Donald Reitz
    Avtex Solutions, LLC
    ------------------------------



  • 11.  RE: Remote number issues

    GCAP Member
    Posted 10 days ago
    Did you try using a different line group and ANI to reach the remote number? - We had a similar issue and this seemed to be a good work around

    ------------------------------
    Ken Woolard
    CarMax Business Services
    ------------------------------



  • 12.  RE: Remote number issues

    Posted 10 days ago
    Edited by Chris Mayo 10 days ago
    Chris,

    I have seen this many times over the years and it's almost always related to dial string formatting. By default, remote station connections are dailed from the Default Location. I know you've mentioned testing the number in dial plan but please be aware of number formating for the specific dial group(line) that is being selected. If you have a specific dial group designated for remote station connections then make sure the number is formatted for the type of call relative to that dial group/line. For example, if the number is long distance for your "default" dial group and local for your designated remote station connection dial group, a "1" prefix may cause the call to fail, "no circuits available".

    It can be very tricky tracking this down so good luck.

    ------------------------------
    Chris Mayo
    Manager, Technical Services
    ConvergeOne
    ------------------------------



  • 13.  RE: Remote number issues

    GCAP Member
    Posted 10 days ago
      |   view attached
    A couple other areas you may want to check:

    1. In IA Default Station Group check the "Remote Station" tab is there a "Line Group" defined there?  screenshot attached
    2. Check if the server parameter "Use Outbound Base Call For Connection" has been configured.
            https://help.genesys.com/pureconnect/mergedprojects/wh_tr/desktop/pdfs/regionalization_dial_plan_tr.pdf
            Page 35  -  Remote station connection calls

    ------------------------------
    Pete Schroeder
    American Customer Care, Inc
    pschroeder@accare.com
    ------------------------------