Genesys Multicloud CX

 View Only
Discussion Thread View
  • 1.  Route On No Answer

    Posted 03-24-2021 04:46
    Hello all,

    We have a odd situation happening with some of our agents which we can't really think why it would be the case.
    In short, we're seeing a lot of call records with Route On No Answer against one particular VQ, whilst other VQs have very low instances of this.
    All of our agents have common profile set ups.  All of them are set up with Auto Answer active.  This has been repeatedly tested and validated working as expected.
    So, we're pretty confused as to which one particular VQ/Skill should be experiencing a hugely disproportionate volume of these results.
    In 'failure' testing we have managed to replicate getting Route On No Answer results, when on Auto Answer, by closing the Agent Desktop app by closing the browser itself.  But we're not convinced this is the cause, given the call patterns and gaps between the agents taking their next call successfully.

    Anyone got experience of this or could suggest what might be the cause?
    #Telephony

    ------------------------------
    Kenny Lang
    Hutchison 3G UK Limited
    ------------------------------


  • 2.  RE: Route On No Answer

    Posted 03-25-2021 17:36
    Hi Kenny,

    I can offer a few thought on what may be happening.  From what we have experienced (and speculated) is that Genesys attempted to connect a specific agent but for some reason was not able o establish a voice connection; in this case the call moved to the next agent in line and Genesys also pushed the first agent to 'Not Ready' since It appeared that agent is not able to take calls.  Are your agents noticing they are being moved out of 'Ready' status on its own?   We have seen this experience mainly with Work from home agents where their home internet/wifi may have fluctuated while Genesys was trying to deliver a call.  We also have some temporary work from home agents using their cell phone for the voice path (since softphone was not possible due a Citrix connection); in these case the voice connection to the cell phone timed out.

    Hope this helps in your investigations.


    ------------------------------
    Davide Giglio
    FCA US LLC
    ------------------------------



  • 3.  RE: Route On No Answer

    Posted 03-26-2021 05:02
    Thanks Davide,

    That's useful insight.  Some of the set up you mention is inline with these agents.
    In the last 2 days, we have started migrating these users off of WebRTC connection for the calls and on to an MPLS connection.
    We're about half way through and have noticed a significant drop in the rate of Route On No Answer.
    The migration to MPLS wasn't being done because of this issue but it seems to be having a positive impact. So, may very well be related to the home set up and the WebRTC connection itself.

    ------------------------------
    Kenny Lang
    Hutchison 3G UK Limited
    ------------------------------



  • 4.  RE: Route On No Answer

    Posted 03-26-2021 08:22
    Hi Kelly,

    Moving from WebRTC to Genesys softphone?  We are on MPLS with Genesys softphones but I am considering going the other way.  Are you moving due to this issue or are there other problems you are finding as well?   A big issue with softphone we have is keeping the softphone software current is very difficult as it does not update on its own, we need to re-install a full application each time; have multiple 3rd party contact centers is not easy to manage and ensure all agents are on the same version level.

    ------------------------------
    Davide Giglio
    FCA US LLC
    ------------------------------



  • 5.  RE: Route On No Answer

    Posted 03-26-2021 10:15
    Hi Davide,

    The reason for the move was local authority governance restrictions.  Where our Contact Centre is based, regulations state call traffic needed to move away from 'open internet'.  Hence the move to MPLS and Softphone to keep us compliant.
    We were looking at all call outcomes, and volumes of them, for separate audit purpose when we spotted a correlation between the volume of instances of 'Route On No Answer' per VQ/Skill decreasing at the same time as the volume of users on those VQs/Skills migrating to MPLS increased (we're phasing over a few weeks).
    On a call unique calls in platform to occurrence of 'Route On No Answer' we've went from it being present on around 2.5% of our traffic to practically nothing now. 2.5% is over 1,000 calls per day for us.
    I'm in the process of checking other KPIs to see if there is any other changes in patterns.

    ------------------------------
    Kenny Lang
    Hutchison 3G UK Limited
    ------------------------------



  • 6.  RE: Route On No Answer

    GENESYS
    Posted 03-26-2021 07:11
    Hello Kenny,

    It can be that value of the application-level options after-routing-timeout/no-asnwer-timeout is too low for that specific group of agents due to network/connectivity delays. In this case modifying after-routing-timeout/no-asnwer-timeout in the Designer application could help. You can do this by attaching corresponding key-value pairs to the calls to affected skill/VQ in the Route Call block > Advanced > Extensions.

    Please raise a new case with Customer Care team if you need any further assistance.

    Thank you

    Best regards,
    Oleg

    ------------------------------
    Oleg Fylypenko
    Genesys - Employees
    ------------------------------



  • 7.  RE: Route On No Answer

    Posted 03-26-2021 10:07
    Thanks Oleg,

    Adjusting the settings would probably be worth a try if we would have stuck with WebRTC (although not sure we would want to from a customer experience side).  Thanks for coming back on this though.  Appreciated.

    ------------------------------
    Kenny Lang
    Hutchison 3G UK Limited
    ------------------------------