Genesys Cloud CX

 View Only
Discussion Thread View
  • 1.  Missed calls with Auto Answer enabled

    Posted 8 days ago
    Edited by Brady Speed 8 days ago
    All of our agents use the desktop app and are configured for auto-answer, however this issue is only affecting a single agent. This agent is hybrid and has encountered the issue working in office and remote.

    Anywhere from 1 - 5 times per week, the agent will get an incoming call alert, auto answer will not kick in, and then 10-12 seconds later the call registers as a missed call. Inspecting the interaction details timeline shows the ACD alerts the agent, and then after waiting the 10+ seconds, the ACD reroutes the call to the next available agent:

    I activated log capture and compared the logs of an interaction where the issue occurred against the logs of the agent recieving a normal interaction. The follow logs were only found in the interaction where the issue occurred:

    32:27.6

    ["pendingSession already exists",{"remoteData":{"conversationId":"07d89ecf-e2a2-4908-9261-5ebda3014be8","message":"pendingSession already exists","extra":[{"kind":"webrtcManager","sessionId":"3ea042ad-d6d4-4391-8334-4da0b4acdfdf","conversationId":"07d89ecf-e2a2-4908-9261-5ebda3014be8","autoAnswer":true}],"clientTime":"2023-01-19T17:32:27.511Z"}}]

    32:27.6

    pendingSession already exists { remoteData: { kind: 'webrtcManager', sessionId: '3ea042ad-d6d4-4391-8334-4da0b4acdfdf', conversationId: '07d89ecf-e2a2-4908-9261-5ebda3014be8', autoAnswer: true, isIncoming: undefined } }

    32:28.5

    Checking for new build { currentVersionHtml: '10.148.1+2-release/10.148.1-bf91f321c79d4c39172e5b6de0d59957817b15b0', currentStreamingServiceVersion: '518' }

    32:30.7

    ["pendingSession already exists",{"remoteData":{"conversationId":"07d89ecf-e2a2-4908-9261-5ebda3014be8","message":"pendingSession already exists","extra":[{"kind":"webrtcManager","sessionId":"3ea042ad-d6d4-4391-8334-4da0b4acdfdf","conversationId":"07d89ecf-e2a2-4908-9261-5ebda3014be8","autoAnswer":true}],"clientTime":"2023-01-19T17:32:30.564Z"}}]

    32:30.7

    pendingSession already exists { remoteData: { kind: 'webrtcManager', sessionId: '3ea042ad-d6d4-4391-8334-4da0b4acdfdf', conversationId: '07d89ecf-e2a2-4908-9261-5ebda3014be8', autoAnswer: true, isIncoming: undefined } }

    32:34.3

    [streaming-client] proceed already sent for this session, but sending another { sessionId: '3ea042ad-d6d4-4391-8334-4da0b4acdfdf', conversationId: '07d89ecf-e2a2-4908-9261-5ebda3014be8', sessionType: 'softphone', isDuplicatePropose: true }

    32:36.7

    Remote versions are the same.

    32:37.3

    [streaming-client] Track removed { conversationId: '07d89ecf-e2a2-4908-9261-5ebda3014be8', sessionId: '3ea042ad-d6d4-4391-8334-4da0b4acdfdf', sessionType: 'softphone' }

    32:37.3

    [streaming-client] Terminating session { conversationId: '07d89ecf-e2a2-4908-9261-5ebda3014be8', sessionId: '3ea042ad-d6d4-4391-8334-4da0b4acdfdf', sessionType: 'softphone' }

    32:37.3

    [streaming-client] Changing session state to: ended { conversationId: '07d89ecf-e2a2-4908-9261-5ebda3014be8', sessionId: '3ea042ad-d6d4-4391-8334-4da0b4acdfdf', sessionType: 'softphone' }


    So far I have not been able to determine root cause. I tried googling "pendingSession already exists," but didn't find any relevant results. Based on what I see in the 141 logs captured during the 12 second alerting period, communication between the agent's client and the Genesys servers remain intact for the duration.

    Has anyone encountered a similar issue or know of a fix?

    Kind Regards,
    #Routing(ACD/IVR)

    ------------------------------
    Brady
    Seattle, USA
    ------------------------------


  • 2.  RE: Missed calls with Auto Answer enabled

    GENESYS
    Posted 5 days ago
    Hello Brady,

    If you haven't done so, filing a Product Support case with all of these details would be my primary suggestion. Folks here in the Community might be able to share their experience on a similar issue, but only Product Support can really make use of all these information.

    ------------------------------
    Nico Feliciano
    Genesys - Employees
    ------------------------------



  • 3.  RE: Missed calls with Auto Answer enabled

    Top 25 Contributor
    Posted 5 days ago
    Could be an issue where the Agent is logged in, in multiple tabs or devices. If you are using WebRTC persistent connection. I take that debug as the webRTC sessions already exists but its trying to create a new one anyway and failing at that. Log out agent from all Genesys Cloud tabs/devices. Log agent back in, have them make a test phone call to establish the WebRTC persistent connection, then try on queue and see if Auto Answer works.

    ------------------------------
    Blake Anderson | Sr. Telecom Engineer
    BEST BUY CO., INC.
    ------------------------------



  • 4.  RE: Missed calls with Auto Answer enabled

    Top 25 Contributor
    Posted 5 days ago
    We are experiencing the same thing, but for multiple agents. No root cause yet. If you find anything please share.

    Our agent's are not on a persistent connection so there shouldn't be existing connections.

    ------------------------------
    Anton Vroon
    ------------------------------



  • 5.  RE: Missed calls with Auto Answer enabled

    Top 25 Contributor
    Posted 4 days ago

    If you are using Auto Answer I would recommend using Persistent Connection. It will deliver calls to your agents faster as it doesn't have to build up and tear down the WebRTC session to the edge every time. Give it a try, that could be your issue. 

    https://help.mypurecloud.com/articles/persistent-connection/



    ------------------------------
    Blake Anderson | Sr. Telecom Engineer
    BEST BUY CO., INC.
    ------------------------------