Genesys Engage on-premises

 View Only
Discussion Thread View
Expand all | Collapse all

Agent Status Shows "Logged off" on Team Communicator and Transfer in WWE multi-site deployment

  • 1.  Agent Status Shows "Logged off" on Team Communicator and Transfer in WWE multi-site deployment

    Posted 03-22-2022 13:38
    Hi,

    WWE Team communicator, all agents are shown as "Logged off" whereas agents are logged-in and performing their contact center activities.

    The architecture of the environment are as follows:

    Site-A
    2 GWS nodes. out of 2, 1 node is syncnode.
    2 ES nodes
    3 Cassandra

    Site-B
    2 GWS nodes,
    2 ES nodes
    3 Cassandra

    the version of the components are as follows:

    Elasticsearch 1.7.5
    Web Services and Applications 8.5.202.68
    Cassandra 2.2.15

    In the cluster application of Genesys Administrator. we provided:
    SS (site-a , site-b)
    SIP Server (site-a , site-b)
    configserver
    ocs (site-a, site-b)




    #ArchitectureandDesign
    #Connect with a Customer
    #Implementation
    #Integrations
    #Routing(ACD/IVR)
    #SIP/VolP
    #Telephony

    ------------------------------
    Noman Hassan
    Tykans Group Inc
    ------------------------------


  • 2.  RE: Agent Status Shows "Logged off" on Team Communicator and Transfer in WWE multi-site deployment

    Posted 03-22-2022 16:50
    I figured out the reason why the Team Communicator isn't working in Multi-Site Deployment.

    In the application.yaml file, the statistics session under serverSettings is disabled by default. you need to enable it and the mandatory settings are:
    elasticSearchSettings:
    enableScheduledIndexVerification: true
    enableIndexVerificationAtStartUp: true

    cheers,



    ------------------------------
    Noman Hassan
    Tykans Group Inc
    ------------------------------