Genesys Engage on-premises

 View Only
Discussion Thread View
  • 1.  Configuration server is not getting started

    Posted 05-10-2022 04:50
    Hi Folks,

    I'm getting below error while starting my configuration server on my test environment.

    [root@shrikant Config_Server]# ./run.sh
    Genesys Configuration Server. Version 8.5.101.95
    Copyright (c) 1997-2022 Genesys Telecommunications Laboratories, Inc.
    Build information :
    Description : (Content Freeze)
    Timestamp : Feb 18 2022 11:04:59
    Version : 8.5.101.95
    Components :
    Configuration library v.8.5.100.48
    Common library v.8.5.100.91 C2 MT-Safe
    Service library v.8.5.100.43 MT
    Message library v.8.5.100.27
    Log library v.8.5.100.56 MT
    LCA library v.8.5.100.38
    Thread library v.8.5.100.38
    DBServer library v.8.5.101.44
    Genesys License library v.8.5.100.15 MT
    License library v.FLEXLm 11.16
    Stat Script library v.8.5.112.23

    (conn_adjust_rlimit) max=4096, current=1024 -> 4096(max) ok
    00:01:48.853 Trc 04112 The Log Output of type 'stdout' has been created and opened
    00:01:48.853 Trc 04110 Option 'level-reassign-disable' has been set to the value 'no'
    00:01:48.851 Trc 04110 Option 'no-memory-mapping' has been set to the value 'no'
    00:01:48.852 Trc 04110 Option 'verbose' has been set to the value 'all'
    00:01:48.852 Trc 04110 Option 'buffering' has been set to the value 'no'
    00:01:48.852 Trc 04110 Option 'expire' has been set to the value '2 file'
    00:01:48.852 Trc 04110 Option 'segment' has been set to the value '100MB'
    00:01:48.852 Trc 04110 Option 'spool' has been set to the value ''
    00:01:48.852 Trc 04110 Option 'snapshot' has been set to the value ''
    00:01:48.852 Trc 04110 Option 'enable-thread' has been set to the value 'no'
    00:01:48.852 Trc 04110 Option 'throttle-threshold' has been set to the value '5000'
    00:01:48.852 Trc 04110 Option 'throttle-period' has been set to the value '30'
    00:01:48.852 Trc 04110 Option 'recovery-timeout' has been set to the value '30'
    00:01:48.852 Trc 04110 Option 'keep-startup-file' has been set to the value 'no'
    00:01:48.852 Trc 04110 Option 'MessageFile' has been set to the value 'confserv.lms'
    00:01:48.852 Trc 04110 Option 'time-format' has been set to the value 'time'
    00:01:48.852 Trc 04110 Option 'time-convert' has been set to the value 'local'
    00:01:48.852 Trc 04110 Option 'message-format' has been set to the value 'short'
    00:01:48.852 Trc 04110 Option 'memory-storage-size' has been set to the value '2 Mb'
    00:01:48.852 Trc 04110 Option 'compatible-output-priority' has been set to the value 'no'
    00:01:48.852 Trc 04110 Option 'print-attributes' has been set to the value 'no'
    00:01:48.852 Trc 04110 Option 'check-point' has been set to the value '1'
    00:01:48.852 Trc 04110 Option 'memory' has been set to the value ''
    00:01:48.853 Std 04106 Log Messages file 'confserv.lms' successfully loaded
    00:01:48.853 Trc 04112 The Log Output of type 'stdout' has been created and opened
    00:01:48.853 Trc 04110 Option 'level-reassign-disable' has been set to the value 'no'
    00:01:48.853 Trc 04100 Logging service started
    00:01:48.856 Std 22129 Locale [] is set successfully.
    00:01:48.857 Std 22110 Encoding [utf-8] is set successfully.
    00:01:48.858 Std 05060 Application started
    00:01:48.858 Std 22100 Genesys Configuration Server. Version 8.5.101.95
    00:01:48.858 Std 22101 Copyright (c) 1997-2022 Genesys Telecommunications Laboratories, Inc.
    00:01:48.858 Std 22102 Server application name is set to [confserv]
    00:01:48.859 Std 22915 Server mode is set to [PRIMARY]
    00:01:48.859 Std 22900 Objectset [main-cfgset] is being loaded ...
    00:01:48.964 Std 22901 Objectset [main-cfgset] : XML schema is loaded
    00:01:49.015 Std 05022 Process './dbclient_msql_64' started
    (conn_adjust_rlimit) max=4096, current=4096 -> 4096(max) ok
    Set parameters: [1],[1],[2],[3],[4],[5],[6],[7],[8],[9],[10],[11],[12]
    00:01:49.108 Std 04503 Connected to Database - main-dbserver 'ConfDB' at host '192.168.16.128', port -1
    00:01:49.108 Std 07001 Database 'ConfDB' opened
    00:01:49.112 Std 22906 Objectset [main-cfgset] : data is cleaned up. Source : [DBServer]
    00:01:49.119 Std 05022 Process './dbclient_msql_64' started
    (conn_adjust_rlimit) max=4096, current=4096 -> 4096(max) ok
    Set parameters: [1],[1],[2],[3],[4],[5],[6],[7],[8],[9],[10],[11],[12]
    00:01:49.209 Std 04503 Connected to Database - dbcontroller 'ConfDB' at host '192.168.16.128', port -1
    00:01:49.209 Std 07001 Database 'ConfDB' opened
    00:01:49.309 Std 23600 Program exception : FATAL ERROR. Locale configured = 1033 Not Loaded!!!
    00:01:49.309 Std 22905 Objectset [main-cfgset] failed to load
    00:01:49.316 Std 05063 Normal termination
    00:01:49.316 Std 05023 Process './dbclient_msql_64' stopped
    00:01:49.317 Std 05023 Process './dbclient_msql_64' stopped


    Database : MS SQL Server 2012
    DB Installed on OS: MS Windows Server 2012
    Configuration Server installed on : CentOS 7 (Linux)
    MSODBC and UnixODBC are installed and configured as below.
    [ [root@shrikant Config_Server]# odbcinst -j
    unixODBC 2.3.7
    DRIVERS............: /etc/odbcinst.ini
    SYSTEM DATA SOURCES: /etc/odbc.ini
    FILE DATA SOURCES..: /etc/ODBCDataSources
    USER DATA SOURCES..: /root/.odbc.ini
    SQLULEN Size.......: 8
    SQLLEN Size........: 8
    SQLSETPOSIROW Size.: 8 ]

    odbc.ini ---->
    [SQLServerDSN]

    Driver = /opt/microsoft/msodbcsql17/lib64/libmsodbcsql-17.9.so.1.2
    Server = 192.168.16.128
    Port = 1433
    User = sa
    Password = Admin@12345
    Database = ConfDB
    Language = us_english
    NeedODBCTypesOnly = 1

    odbcinst.ini --->

    [SQL Server]
    Description=SQL Server
    Driver=/opt/microsoft/msodbcsql17/lib64/libmsodbcsql-17.9.so.1.1
    UsageCount=1


    Can someone please help to understand what exactly is missing in any configuration I made?


    Regards,
    Shrikant




    #GenesysEngageDev

    ------------------------------
    Shrikant Sontakke
    The Customer Experience Lab
    ------------------------------


  • 2.  RE: Configuration server is not getting started

    Posted 05-11-2022 03:12

    Hi,
    I assume that cfd DB is prepared and works fine - you can login in and review tables there ?

    Why in *.ini not used the same driver version ?

    Regards



    ------------------------------
    Piotr Gordon
    codelab.eu Poland
    ------------------------------



  • 3.  RE: Configuration server is not getting started

    GENESYS
    Posted 05-11-2022 06:29
    Hello Shrikant,

    The problem seems to be with the Locale.

    00:01:49.209 Std 07001 Database 'ConfDB' opened
    00:01:49.309 Std 23600 Program exception : FATAL ERROR. Locale configured = 1033 Not Loaded!!!
    00:01:49.309 Std 22905 Objectset [main-cfgset] failed to load

    Is this a new Config DB? If so can you confirm if you have initialized it with both the scripts below. It looks like you missed the CfgLocale_mssql.sql during DB initialization.

    1. init_multi_mssql.sql (single language) or init_multi_multilang_mssql.sql (multi-language)
    2. CfgLocale_mssql.sql (Locale)


    ------------------------------
    Vinod Balan
    Genesys - Employees
    ------------------------------



  • 4.  RE: Configuration server is not getting started

    Posted 05-12-2022 03:09
    Dear Vinod,

    Thanks for your details.
    Both queries were already executed at DB (ConfDB) but when in run command ./run.sh, I was getting error as shared earlier.
    Changes which I made : Deleted the existing DB (ConfDB) and created new one as Config_DB and re-run the both queries and it worked. I suspect the old DB name was not taking up.

     now the Config server is up and running.


    Thanks for the help guys!

    Regards,
    Shrikant

    ------------------------------
    Shrikant Sontakke
    The Customer Experience Lab
    ------------------------------