PureConnect

 View Only
Discussion Thread View
  • 1.  Screen Recording transfer service not binding to NetMotion VPN adapter

    Posted 09-02-2020 17:08
    PureConnect brain trust,

    I am facing an issue with 2 separate implementations, where Agents have been sent home with PC's and are using NetMotion for VPN connectivity back to the home office.  All aspects of PureConnect work well with the exception of the Screen recorder transfer service.  The screen captures are being performed correctly (to the best of our knowledge), data is being written to the DB, but the i3SR files can't be moved off the remote PCs to the RCS/default storage location on the corporate network.

    Logs indicate that the transfer service is trying to use the Local LAN adapter to transfer the files and obviously can't access any of the corporate resources needed.

    All affected PCs are Windows 10 (Windows 7 PCs work fine) and if an affected PC is on the corporate LAN, SR transfer works fine.  We have tried uninstalling and re-installing PureConnect User Apps while connected to the VPN with no positive effect.  ININ QoS driver appears and is checked in the NetMotion adapter properties.

    Has anybody seen this issue and are there any workarounds?  I have heard rumors that setting up static routes have a positive effect, but have not tried that as of yet.

    #QualityManagement

    ------------------------------
    Regards, Blayne
    Technical Account Manager
    Altivon, A ConvergeOne company.
    ------------------------------


  • 2.  RE: Screen Recording transfer service not binding to NetMotion VPN adapter

    Posted 07-11-2022 12:21
    Hi Blayne

    Were you able to find a solution for this?

    ------------------------------
    Jonathan Obniala
    EPCOR Utilities Inc
    ------------------------------



  • 3.  RE: Screen Recording transfer service not binding to NetMotion VPN adapter

    Posted 07-12-2022 08:29
    I have a customer who also uses NetMotion VPN.  We have the same problem.  The issue was supposed to be resolved with an SCR:
    SCR: IC-159439
    Product: xIC
    Status: Resolved
    Resolution: FITC
    Built in version: 2021r3, 2020r4 Patch 13, 2020r1 Patch 31, 2020r3 Patch 19, 2020r2 Patch 27, 2021r2 Patch 3, 2021r1 Patch 9
    Description: Completed a change in capture client start up to handle late network connections.
    Details: Improved the connection between capture transfer service and capture client during startup.

    We installed 2021 R3 P4, but I still have issues with screen cap file transfers.
    Prior to applying the patch, I created a pair of batch files (triggered by Task Scheduler) that transfer files from the ScreenRecs folder on the user PC to an on-prem server (1), but only when they lock their PC.  Transferring the files while taking calls can create audio issues because there is no QoS.  The on-prem server1 has a batch file that transfers to another on-prem server2, where I have Int Desktop installed.  This 2nd server has Task scheduler batch files that stop the built-in transfer app, then moves all of the .i3sr files to the ScreenRecs folder for normal processing.  Once all the files are moved over, the built-in screen rec transfer service is restarted and the files are processed 2 at a time.  I have adjusted config.xml to transfer the files quickly. I have to stop the built-in transfer service because it will start transferring partially copied files if I don't.  This could have been accomplished with fewer moves, but originally, I was using a desktop for the built-in transfer phase.
    Since the patch failed to resolve the problem, I am still relying on my batch files to move screen recs.

    ------------------------------
    Donald Reitz
    Avtex Solutions, LLC
    ------------------------------



  • 4.  RE: Screen Recording transfer service not binding to NetMotion VPN adapter

    Posted 07-12-2022 10:15
    Hi Donald,

    Thank you for the information. That was also one of the suggestions from the Genesys technical support to move the screen rec files to a PC that was local on the LAN. I will definitely take a look at your suggestion and try to replicate a similar scenario. Its been very challenging to get an answer from the Genesys side or our security side as we keep going back and forth on this issue.

    One thing we found was that rebooting the home router of the user seems to fix the problem temporarily but eventually the screen recorder looks at the home IP again rather than the corporate IP assigned. Did you have any insights on why this would happen during your investigation?

    Thank you again for the helpful information.

    PS: We also applied the patch as well.

    ------------------------------
    Jonathan Obniala
    EPCOR Utilities Inc
    ------------------------------