PureConnect

 View Only
Discussion Thread View
  • 1.  Switchover Errors

    GENESYS
    Posted 12-18-2013 14:02
    Hello all, I have environment with CIC servers in switchover pair. For some reason, often initiates switchover. In inin tracing log SwitchoverFileMonitor i found this errors: CPingProvider::Run : WaitForSingleObject timed out, sending ping CPingProvider::Run : Error sending ping, rc=10065 CPingProvider::Run : WaitForSingleObject timed out, sending ping CPingProvider::Run : Error sending ping, rc=10065 and after this errors switch was initiated. Whether all this is cause of a network problem or something else?


  • 2.  RE: Switchover Errors

    Posted 12-18-2013 15:12
    Ping timeout would usually mean the backup CIC server was unable to ping the primary server and thus initiated a switchover. When the switch is initiated does the primary go into failed status or do you end up with 2 primaries? Are you 2 CIC servers in the same data center or are they across a WAN? Does this happen often or was it a 1 off? If this happens often I would check the network to see why the 2 CIC servers are unable to communicate. Also according to the swtichover documentation the recommendation is you use a dedicated NIC with a crossover cable between the 2 CIC servers, although this is not practical. If all else fails there are some optional server parameters for switchover you can leverage to adjust the time the ping waits and how many have to fail before the backup server initiates the switchover.