PureConnect

Discussion Thread View
Expand all | Collapse all

Missing User's Names

  • 1.  Missing User's Names

    Posted 01-19-2016 17:44
    Running 2015 R3 P11 Using Exchange When we add a mailbox to a user in IA, the personal info tab is populated with the users data, First name, Last name .etc,. When we pull the User Productivity Report in ICBM using a user list, these users with mailboxes are missing their first name and last name, other users are not missing that data. When we go to the individuals table in the database, these users are also missing their first and last names. All other users have this populated. Has anyone ran into this issue? I always check on her before opening a case with ININ. Thanks, Ang


  • 2.  RE: Missing User's Names

    GENESYS
    Posted 01-19-2016 18:31
    Ang, I'm not sure how long the system waits to populate that database table with new user info. The default for pulling info into IC from Exchange is every 15 minutes, but it may take longer for the info to be written to the DB...maybe nightly? That said, I am on 2015 R4 (but not connected to Exchange), and when I add the First and Last name to a user, they write to the database immediately. Maybe because I triggered that action from IA. How long have you waited for the user data to show up? If longer than 24 hours, then it sounds like something is amiss.


  • 3.  RE: Missing User's Names

    Posted 01-19-2016 18:45
    Yes, it's been weeks. Because the data is populated by exchange, the personal info tab info cannot be modified. All other users (without the mailboxes) that have manually had their personal info entered into IA are appearing without issue. We are having Tracker Duplication issues too. We are waiting on the DBA to run the provided script from ININ, then we will pull the Tracker Data again and see if that fixes the issue. We are in a holding pattern so I thought I'd see if anyone else had seen it before.


  • 4.  RE: Missing User's Names

    GENESYS
    Posted 01-19-2016 19:05
    Have you tried turning tracing to Notes on the DataManager subsystem and checked the logs for errors? Also, ExchangeConnector? You mentioned Tracker issues...Here is something I found regarding an old system issue found in 2.3, but which was listed as INVALID. I am wondering if it has been around for a long time, but never fixed... 1) Create a new user with the mailbox info specified in IA. The individual table will be updated with the first and last name along with a new record. 2) Create a user without the mailbox info specified. The new user will be added with out the first and last name as expected. Now go back into IA and select a mailbox for this user. Tracker should update the individual record with the first and last name, but doesn't. A valid workaround is to use the Interaction Tracker configuration node in IA and re-import the IC Users. This will force an update of the first and last name.


  • 5.  RE: Missing User's Names

    Posted 01-19-2016 19:31
    I think we will try that after the scripts has been run to remove all of these duplicate users. Sounds to me like it has been around for a bit. Ang