PureConnect

Discussion Thread View
Expand all | Collapse all

Multilingual recordings with Attendant

  • 1.  Multilingual recordings with Attendant

    Posted 09-21-2017 15:23
    Has anyone else had problems with the prompts that let you do recordings in other language than English? We are running a bilingual system. When recording single files with Attendant the prompt let me record in default language and then gives me option to record in "other" language. When I select this option I hear "for (silence), press 1, for (silence), press 2" It does not actually speak the name of language to select. You have to guess that you have the default language (in this case English) on option 1, and the other language at option 2. We had this on v. 4.0 SU6, we still have the same after upgrade to 2016 R4. We've been told that (on 4.0 SU6) this is an issue with some background handlers, but it seems like it may be a simple configuration problem because the recording process works, it just doesn't speak the language name. Has anyone else encountered this?


  • 2.  RE: Multilingual recordings with Attendant

    Posted 09-21-2017 16:35
    I have never used the function but I suspect that the missing language prompt has to be writing an error somewhere. First look at the event log on the server and see if it is writing errors about a prompt missing. If you can identify what prompt is missing then you can add the missing prompt and you should hear it. Otherwise you may have to look in the IP log (assuming IP is what is playing the menu that has the missing prompts). You may have to do a bit of digging to figure this out but if is truly a bug in the system your Var should be able to get a workaround from genesys.


  • 3.  RE: Multilingual recordings with Attendant

    Posted 09-27-2017 16:40
    Originally posted by MarkT;35886
    I have never used the function but I suspect that the missing language prompt has to be writing an error somewhere. First look at the event log on the server and see if it is writing errors about a prompt missing. If you can identify what prompt is missing then you can add the missing prompt and you should hear it. Otherwise you may have to look in the IP log (assuming IP is what is playing the menu that has the missing prompts). You may have to do a bit of digging to figure this out but if is truly a bug in the system your Var should be able to get a workaround from genesys.
    I run a debug session on this and found that the IntAttRecordPrompt handler is unable to voice this: We do not have a TTS license, so unless the system should be capable of doing a limited TTS for the system prompts those two items seem to be defined incorrectly. Off to the InIn technical support it goes...


  • 4.  RE: Multilingual recordings with Attendant

    GENESYS
    Posted 09-27-2017 17:26
    It tries to use Microsoft TTS if you don't have another TTS engine. See if you can add a Canadian French option to Windows...maybe with a Windows language pack? https://technet.microsoft.com/en-us/library/hh824829.aspx


  • 5.  RE: Multilingual recordings with Attendant

    Posted 10-02-2017 13:52
    Originally posted by GGanahl;35905
    It tries to use Microsoft TTS if you don't have another TTS engine. See if you can add a Canadian French option to Windows...maybe with a Windows language pack? https://technet.microsoft.com/en-us/library/hh824829.aspx
    We are on hosted solution, so I would have to ask our service provider to get Microsoft TTS for French on our server. But then, shouldn't it work for English as is? Or do we need to have something configured on the Interactive Intelligence system side (IAdministrator ?) to actually use the Microsoft TTS?