PureConnect

Discussion Thread View
Expand all | Collapse all

SIP SoftPhone Provisioning

Jump to Best Answer
  • 1.  SIP SoftPhone Provisioning

    Posted 07-23-2019 13:56
    Hi folks. We have an offsite team that has set up shop a couple hundred miles away from our primary site. The team has client laptops with SIP SoftPhone configured in IC User Apps (IC 2019 R1 p2): the users are unable to provision the softphone when attempting.After running the SP SoftPhone application and having the "SIP SoftPhone Provisioning Wizard" open, after clicking Next the user sees "Querying DHCP server, please wait.." - whereas for typical users this appears for a fraction of a second, for the offsite team it stays visible for up to 10 seconds. Then the Provisioning Wizard closes/crashes. Myself and another IT rep tried RDP'ing into some of these laptops and we were able to provision it under our logins without issue. We even tried uninstalling & reinstalling the program, with identical results (works for us, fails for offsite users): so it seems to be a user-specific problem. Has anyone encountered a similar issue previously? We've had a case open with managed services for a few weeks now and there has been no progress so far.

    Thanks,
    Ric
    #SIP/VolP

    ------------------------------
    Ric
    IKEA U.S. East, LLC No. 159
    ------------------------------


  • 2.  RE: SIP SoftPhone Provisioning

    GENESYS
    Posted 07-23-2019 14:46
    Do you control DHCP for the remote site? If so, make sure Option 160 is set correctly.

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------



  • 3.  RE: SIP SoftPhone Provisioning

    Posted 07-24-2019 12:21
    Hi Paul,

    Our business has a global support team that manages network resources. They had previously advised that the DHCP option 160 was configured; but I've queried them to re-check and verify.

    Thanks,
    Ric

    ------------------------------
    Ric
    IKEA U.S. East, LLC No. 159
    ------------------------------



  • 4.  RE: SIP SoftPhone Provisioning
    Best Answer

    Top 25 Contributor
    Posted 07-24-2019 10:39
    Ric,

    There is an old bug in a few CIC applications which won't display right, or crash, if DPI scaling in Windows is set to anything other than 100%. It looks like this SCR is fixed in 2019 R1 P6. By default it looks like Windows detects it is running on laptops and tries to be helpful setting scaling to 125%. You can either set the DPI scaling to 100% or apply patch 6.

    For your info here is the info on the SCR:

    Component: SIP Soft Phone - UI

    IC-152010
    If we increase the DPI scaling to anything over 100% the SIP Softphone will crash immediately when we click the provision option.
    If we increase the DPI scaling to anything over 100% the SIP Softphone will crash immediately when we click the provision option. This code change fix the issue to auto adjust the width of control which is causing the crash when we increase the scaling.
    Device/Install Hint:
    Work

    Thanks,

    ------------------------------
    Mark Tatera
    ConvergeOne

    Opinions are my own and not the views of my employer. Any suggestions or programming changes I suggest come with no warranty and should be tried at your own risk.
    ------------------------------



  • 5.  RE: SIP SoftPhone Provisioning

    Posted 07-24-2019 12:26
    Mark,

    You may be onto something. I pulled a laptop from our primary site and logged in. Found DPI scaling was already set at 150%, so I attempted provisioning. I experienced the exact same problem as the offsite users. When I changed DPI to 100% & retried... provision successful.

    I just sent instructions to the offsite users and asked them to check whether this could indeed be the cause of the issue for them. Hope to have some feedback soon.

    Thanks,
    Ric

    ------------------------------
    Ric
    IKEA U.S. East, LLC No. 159
    ------------------------------



  • 6.  RE: SIP SoftPhone Provisioning

    Posted 07-24-2019 12:42
    Mark,

    You were right on with this. Just heard back from our offsite users: once they changed the DPI scaling & rebooted, they were able to provision successfully.

    Thank you so much :-)

    Ric

    ------------------------------
    Ric
    IKEA U.S. East, LLC No. 159
    ------------------------------