PureConnect

 View Only
Discussion Thread View
  • 1.  Interaction Media Server

    Posted 12-12-2021 00:15
    Hi,

    While adding command server (part of media server config), I am getting below error -


    Also tried adding server using REST API http://192.168.1.182:8084/api/v1/commandservers, which also fails with error show below -

    Authentication Failed

    You are not authorized to view this page!

    Please ensure you supply the correct credentials. If you were not prompted for a
    username and password, ensure your browser supports HTTP Digest authentication.

    I have enabled the REST API using media server configuration.

    Any help/pointers are appreciated.

    Thanks.
    #PureConnectQAEpisode

    ------------------------------
    Sukhadeo Prasad
    Consilium Software Inc Pte Ltd
    ------------------------------


  • 2.  RE: Interaction Media Server

    Posted 12-12-2021 09:11
    Hi Sukhadeo,

    This error means the username and password you entered when building the connection is not correct. This username and password should be a local  user Account on the PureConnect system that has admin privileges.

    Thank you,
     Scott

    ------------------------------
    Scott WilliAMs
    Missouri Higher Education Loan Authority
    ------------------------------



  • 3.  RE: Interaction Media Server

    Posted 12-12-2021 13:20
    Edited by Sukhadeo Prasad 12-12-2021 13:21
    Hi WilliAMs,

    Thanks for your reply ,
    for your information , I have tried with Local user Account as well on the PureConnect system which has admin rights but still the result is same . also , I have set the REST API credentials in interaction media server but getting 401 Unauthorized  .

    Authentication Failed
    You are not authorized to view this page!

    Please ensure you supply the correct credentials. If you were not prompted for a username and password, ensure your browser supports HTTP Digest authentication.

    Thanks.
    #PureConnectQAEpisode

    ------------------------------
    Sukhadeo Prasad
    Consilium Software Inc Pte Ltd

    ------------------------------
    Sukhadeo Prasad
    Consilium Software Inc Pte Ltd
    ------------------------------



  • 4.  RE: Interaction Media Server

    Posted 12-13-2021 06:03
    To add a Media Server you need "IC Authentication" enabled. If you only use Windows Intergrated Authentication you must switchon "IC authentication" in

    IC Administrator / System Configuration / Configuration / Connection Security / Configure Login Authentication

    then add the Media-Server. Afterwards you can restore the original authentication settings.

    ------------------------------
    Andreas Tikart
    Fiebig GmbH
    ------------------------------



  • 5.  RE: Interaction Media Server

    Top 25 Contributor
    Posted 12-13-2021 12:20
    Related to this, common issue in class, make sure you are using the IC password and not the Windoze one!

    ------------------------------
    Paul Simpson
    Senior Technical Instructor
    ------------------------------