PureConnect

 View Only
Discussion Thread View
  • 1.  High Availability Database Configuration

    Posted 05-17-2022 09:32

    Hi All,

    I am working through the process of moving our system to look at a listener instead of hardcoded to a SQL server and database directly.  The issue i have ran into is when i am at the point in setup assistant to enter the database, it tells me

    "The named database cannot be used since an earlier version of the database exists. Please upgrade this database or enter another database name"


    This is the same database we connected to, just moved to a different SQL server that has High Availability configured. Has anybody ran into this before? my SQL admin says the everything about the database is the same.


    #SystemAdministration

    ------------------------------
    Scott Williams
    Missouri Higher Education Loan Authority
    ------------------------------


  • 2.  RE: High Availability Database Configuration

    Posted 05-18-2022 09:01
    you have to run the Setup Assistant using TLS 1.0 and a SQL SA account and select the upgrade option.  If you are trying to use the listener, you will need to use Native Client 11.4.7469.6 and select the option " Multi-subnet failover" under the ODBC connection

    ------------------------------
    Jayson Aggen
    Avtex Solutions, LLC
    ------------------------------



  • 3.  RE: High Availability Database Configuration

    Posted 23 days ago
    Hi Jayson,

    The issue was with our last update to 2021 R4 the Database tables were not updated, so the ININ_APP_VERSION was still showing the old Version of PureConnect. This was because we did not have TLS1.0 enabled when updating.

    Side note i thought Setup Assistant utilizing TLS1.0 was resolved 2019 R1 (SCR IC-145885). But looks like it is only resolved utilizing Setup Assistant when testing the connection to the database and does not resolve the issue with the DB update scripts utilizing TLS1.0. So looks like TLS1.0 is required for Upgrades.

    Thank you,

    ------------------------------
    Scott Williams
    Missouri Higher Education Loan Authority
    ------------------------------



  • 4.  RE: High Availability Database Configuration

    Posted 23 days ago

     SCR IC-154614 , you have to enable TLS 1.0 to get the setup assistant to run with the updated Native Client or manually run the Script on the DB in the below order to update this table

    Run the following scripts/sprocs in the order presented:

    spinin_create_user_database.sql
    spinin_create_user_database <db> <data> <log> <init> <max> <inc> <init> <max> <inc>
    spinin_setup_database_user.sql
    spinin_setup_database_user <db> <lang> <user1> <pwd1> 8192
    spinin_setup_database_user <db> <lang> <user2> <pwd2> 33024
    spinin_setup_database_user <db> <lang> <user3> <pwd3> 256
    ICBuild.sql
    TrackerBuild.sql
    OptimizerBuild.sql
    IRBuild.sql
    CSSurveyBuild.sql
    WorkflowBuild.sql
    IWPBuild.sql
    DialerBuild.sql
    AnalyticsBuild.sql



    ------------------------------
    Jayson Aggen
    Avtex Solutions, LLC
    ------------------------------