Genesys Cloud - Main

 View Only

Discussion Thread View
  • 1.  One-Way Audio

    Posted 04-12-2024 14:29

    Handful of users experiencing one-way audio: customers can hear them, but they cannot hear customers. However, proper two-way audio is being recorded during interactions. Have verified WebRTC settings and audio and have tested successfully through both native Genesys Cloud and Salesforce plugin, and sound settings and drivers are correct on users' respective machines. Users' audio functions properly through other audio programs on their machines. Thanks for any suggestions!


    #Telephony

    ------------------------------
    Gavin Hoffman
    Myriad Genetics, Inc.
    ------------------------------


  • 2.  RE: One-Way Audio

    Posted 04-15-2024 12:55

    Hi Gavin,

    We have identical symptom in 2 INC reported today.  NA East Region.

    The customer clearly hears the audio from the Agent (as evident in the recording) but the agent does not hear the customer,, and reports hearing silence.

    We are opening case.  



    ------------------------------
    John Korn
    Johnson & Johnson Services, Inc.
    ------------------------------



  • 3.  RE: One-Way Audio

    Posted 04-15-2024 21:04

    Gavin, had you opened a support ticket for this issue ?  

    Any internal findings on cause ?   we have a case open, and will be enabling the media capture logging for any potential re-occurance.

    thanks

    John



    ------------------------------
    John Korn
    Johnson & Johnson Services, Inc.
    ------------------------------



  • 4.  RE: One-Way Audio

    Posted 04-16-2024 20:05

    We are also having the same issue with disconnect reason being Endpoint on the user end. We already have a ticket opened with support but honestly, we are not getting too far. The only recommendation is for us to engage with our network team.

    Apparently, it is caused by icedIdleDetection which according to them is:

    "This happens when our Media service detects no packet being received from connectivity checks that it sent towards the remote endpoint (webrtc station). If the remote endpoint did not respond to those outgoing checks for 15secs, the media link will be terminated and tagged the interaction as Agent Disconnect since it was the Agent who stop communicating to Genesys Media Service. Apparently, this issue is related to performance issue on the Agent station which not being managed by Genesys."

    It's just odd that we are seeing much more of this issue recently. I do have trust issues with support. Last year they were adamant it was our networking issue, but it turned out that the edges they provided was not large enough and would cause issues when it was scaling up.



    ------------------------------
    Tony Nguyen
    Smartgroup
    ------------------------------



  • 5.  RE: One-Way Audio

    Posted 04-17-2024 10:30

    Interesting you bring this up:

     What you are referring to is not part of this overall thread..  but often get the same explanation for when calls drop during mid--conversation.

    Just had this analysis come back on a call drop 2 mins 50 seconds into an active conversation.

    User was onsite - hard wire LAN - ISP circuit showed no errors, Nexthink PC performance tools showed nothing out of ordinary.

    "checked the logs behind the interactions other than only the SIP logs and found this error: 480 WebRTC Disconnect. The basis of this error is that we stop receiving RTP from the agent's station for 10 seconds, at which time the interaction is automatically disconnected. I'm including some more information about this error below

     After investigating, we are seeing what's called an IceIdleDetection error."



    ------------------------------
    John Korn
    Johnson & Johnson Services, Inc.
    ------------------------------



  • 6.  RE: One-Way Audio

    Posted 04-17-2024 10:38

    This is interesting.

    I have a customer who was experiencing similar issues for very short (but intense) periods. In their case, calls were randomly dropped which increased for a period of about 24 hours and then fell back to normal levels again. They were also seeing a lot of IceIdleDetection errors. What made this more challenging to troubleshoot is that there doesn't appear to be any way to get ac report / set an alert of this happening. The "evidence" had to come from Agent's using a "Call Dropped" Wrap-Up code, which isn't exactly accurate!

    We ended up having Genesys perform a network evaluation which didn't show anything of particular note. The problem appears (so far!) to have disappeared, but I will be keeping an eye on this thread to see if there are any commonalities / what the issue turns out to be (if found.)



    ------------------------------
    Paul Simpson
    Views expressed are my own and do not necessarily reflect those of my employer.
    ------------------------------



Need Help finding something?

Check out the Genesys Knowledge Network - your all-in-one access point for Genesys resources