View Only

Discussion Thread View
  • 1.  IPA Utilities, Launching a Process

    Posted 08-03-2015 16:12
    Hello, We are on 2015 R2 Patch 10. When we try to use the IPA Launch process in SOAP we are getting the following error: Exception while starting the process: Feature License required for this operation is missing. This worked before our upgrade, and we do have the valid licenses. Any ideas from anyone would be very helpful to us. Ang

  • 2.  RE: IPA Utilities, Launching a Process

    Posted 08-04-2015 01:02
    What is behind the SOAP service? I assume it is IceLib judging by the error message and the 2+ month case I've just had open with support on this very issue. Basically, they made a change so that you have to request the license now. There is a license request class that you'll need to use to request the icelib license for your connection (it isn't automatic like before). Unfortunately, I don't have the case # or the code with me, but it shouldn't take too long to figure out. I'll post examples tomorrow, but you should have enough to get going if you really need it tonight. I've already complained about the change in functionality without documenting it, but you should complain as well. --JAson

  • 3.  RE: IPA Utilities, Launching a Process

    Posted 08-04-2015 13:42
    here is my code, let me know if you need the support case #: I have bolded the pieces that I had to add after I moved to 2015 R2. return lib_Common.runCode("ipa_LaunchProcess", () => { var sLicense = lib_Common.getConfigValue("IPA License", String.Empty, true, "I3_ACCESS_IPA_USER"); LicenseManagement lm = new LicenseManagement(lib_ICELIbConnectionCache.Instance(connection).peopleManager); lm.StartWatching(new string[] { sLicense }); Tracing.TraceNote(String.Format("ipa_LaunchProcess::License = {0}, Assigned = {1}", sLicense, lm.IsLicenseAssigned(sLicense))); if (lm.IsLicenseAssigned(sLicense)) { var result = lm.LicenseOperation(new List<LicenseRequest> {new LicenseRequest(sLicense, LicenseRequestType.Request)}); Tracing.TraceNote("ipa_LaunchProcess::License request result = " + result.First().ToString()); } ProcessManager.GetInstance(lib_ICELIbConnectionCache.Instance(connection).session). LaunchProcessByName(processName, CreateProcessLaunchParams(input)); return new operationResult(); }); }

  • 4.  RE: IPA Utilities, Launching a Process

    Posted 08-05-2015 12:26
    Yes, please let me know your case number and I will reference it in mine. Thank you for the information. I hope this works for us. I appreciate your time. Ang

  • 5.  RE: IPA Utilities, Launching a Process

    Posted 08-05-2015 14:00
    I wanted to reply back how we have used this feature in the past, before the upgrade. We did not use Icelib (that I know of). We added Interactions 2013 and Interactions - Eventing to IC Server Manager, then on one of our online applications, that our users use, on the click of a button it kicks off the code that launches our selected IPA process with the username and password that we supply as the "launcher" Like I said, it worked before the upgrade and now we are having this Feature License issue. I just wanted to clarify. It still seems as though you and I are having the same issue, but with different launching processes. Ang

Need Help finding something?

Check out the Genesys Knowledge Network - your all-in-one access point for Genesys resources